PHP Your requirements could not be resolved to an installable set of packages

· 如故 · 75阅读 · 2022-08-03

详细描述

首次安装PHP+Larael,执行composer install 报错

版本信息

PHP8;Larael 9.2;composer2.3.*

复现过程

执行composer install ,composer update 等命令时报错

解决方案

以上是由于版本问题导致,在执行composer命令时可以选择忽略版本检查(composer官方说明PHP7以上就可以运行composer,建议还是找到相应版本进行安装)

 composer install --ignore-platform-reqs
或者
composer update --ignore-platform-reqs

文章有用

已有 1人 推荐该文章,推荐越多越容易获得的官方扶持

微信扫码分享